Back to overview
Downtime

Connection Timeouts on kestrel.chat

May 22, 2026 at 11:58pm UTC
Affected services
Landing Page

Resolved
May 23, 2026 at 12:14am UTC

The issue causing connection timeouts on kestrel.chat has been resolved.
Landing page is now fully operational!

Created
May 22, 2026 at 11:58pm UTC

We are currently investigating an issue causing connection timeouts when accessing kestrel.chat. Users may experience failed connections or slow/unresponsive requests.