Back to overview
Downtime

Landing Page is unavailable

May 2, 2026 at 5:35am UTC
Affected services
Landing Page

Resolved
May 2, 2026 at 5:46am UTC

The issue affecting the landing page has been resolved. Service has been fully restored following the DNS migration.

Created
May 2, 2026 at 5:35am UTC

The landing page is currently unavailable for all users due to an issue encountered during a DNS migration. We are actively working to resolve this and expect service to be restored within 24 hours.